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Knowledge Base

  

Problem

When you try to install a certificate from a PKCS#7 file by using Internet Information Services (IIS) 7.0 Manager, you may receive one of the following error messages may occur:    

“Cannot find the certificate request associated with this certificate file. A certificate request must be completed on the computer where it was created.”

OR

“There was an error while performing this operation
Details: CertEnroll::CX509Enrollment::p_InstallResponse: ASN1 bad tag value met. 0x8009310b (ASN:276)”

We should see that the certificate is installed correctly despite the error message.


Cause

IIS Manager performs a lookup operation to look for a friendly name of the certificate during the installation.
However, the code that performs this lookup operation misses this specific case, and it does not know how to retrieve the friendly name of a certificate in a PKCS#7 file.
As a result, the lookup operation fails, and you receive the error message.


Resolution

To resolve this problem, add a friendly name to the certificate by following these steps:

1.     Click Start, click Run, type certmgr.mmc, and then click OK.

2.     Locate the certificate.

3.     Right-click the certificate, then click Properties.

4.     Finally, edit the Friendly name field.

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